I'm trying to list all the utxo's at my Yoroi wallet address. I set the variable 'address' as my receiving address but when I run the command, cardano-cli query utxo --address $address --mainnet, nothing shows up. I also tried this for a Daedalus wallet I have used often and I get the same result (will include a screenshot below). I can confirm there have many tx to and from this wallet so I'm confused why this is the case. I'm using the same linux VM for this command which I have a cardano-node running and synced up to the chain in. Any help is much appreciated!

Thanks, Myles

enter image description here

2 Answers 2


It is because Yoroi generates a new address after each transaction for privacy reasons. People who only know this address cannot see how much funds you have and what transaction you did in the past. At the same time your wallet can with its private key derive all address and show to you all the funds you have.

Try taking the last address where you received funds. It is displayed in the transaction tab in Yoroi. This address should show some UTxOs if you do the same query.


Cardano-wallet software (which both Daedalus and Yoroi use extensively) derives addresses from a single master key, as described in the BIP-32 standard. This key-derivation is briefly summarized by this infographic:

enter image description here

As you can see, many addresses can be derived from a single master key. Yoroi and Daedalus automatically create and maintain many such addresses for anonymity purposes, since one cannot prove ownership of two or more addresses without possessing the associated keys.

What likely happened in your scenario is you've sent ADA to one of the addresses created by Yoroi, but queried a different address (also created by Yoroi). To solve this, query the same address that you sent the ADA to (as found on a block explorer like cardanoscan, or in the history of wherever you sent the ADA from.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.