3

I am trying to implement Martify contract using Cardano serialization lib. When I submit the transaction I get the following error. Can someone tell me what it mean?

transaction submit error ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (UtxosFailure (ValidationTagMismatch (IsValid True) (FailedUnexpectedly [PlutusFailure \"\\nThe 3 arg plutus script (PlutusScript ScriptHash \\\"a306c90d19adfd7302e6d0a452aed3bd1d7f08e5b291d1add3d8e4fb\\\") fails.\\nCekError An error has occurred: User error:\\nThe provided Plutus code called 'error'.\\nThe data is: Constr 0 [B \\\"\\\",I 100000000,B \\\"B\\\\DLEGO\\\\251\\\\142\\\\170Lpz6u\\\\155Tf\\\\223\\\\208\\\\173X]\\\\237\\\\143X\\154%\\169\\n\",B \"\"]\nThe redeemer is: Constr 0 []\nThe context is:\nPurpose: Spending (TxOutRef {txOutRefId = 0ba3

10
  • I am impressed since it appears that the shared repo is for submitting using cardano Cli! and Nami specs don't match cardano-cli specs..but the error seems at a first look to be bassed on executing the plutus scripts... have you tried with this same transaction in the cli? to check if it is related to cardano serialization lib or to the contract perse? Dec 7, 2021 at 2:27
  • I did try the same transaction through Cardano-cli which seems to be working perfectly fine. But when using Cardano-serialization-lib it keep on giving me this script failed eeror
    – Dawar Ejaz
    Dec 7, 2021 at 6:02
  • ive read in Alessandro Twitter that Nami does not suport plutus contracts. But i am not sure why it is the case.. since is is a normal Tx just with redemer and plutus scripts. so you took the plutus script, and used the cardano serialization lib to make the rest of the transaction?.. Maybe you should try to sign it using your prv keys in the library and send once int is signed. Dec 7, 2021 at 20:27
  • I'm experiencing the same error. No idea what I'm doing wrong...
    – Displee
    Dec 20, 2021 at 0:18
  • 4
    Lol I solved this issue. I was using a wrong tx id in my script utxo and the address in the datum was wrong too. Had to use ownerAddress.payment_cred().to_keyhash()?.to_bytes().
    – Displee
    Dec 22, 2021 at 13:34

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.