4

I have a working transaction in cardano-cli, but I'm having trouble constructing the same one using the serialization-lib. Does anyone know what these errors mean?? I tried looking into the typescript definitions, but the documentation isn't great.

""transaction submit error ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [
UtxowFailure (NonOutputSupplimentaryDatums (fromList [SafeHash \"9cbcced629edb13ecef78c9c27adfe079a9acd77b62a6693eab0134920a595b9\"]) (fromList [])),
UtxowFailure (ExtraRedeemers [RdmrPtr Spend 1]),
UtxowFailure (WrappedShelleyEraFailure (MissingScriptWitnessesUTXOW (fromList [ScriptHash \"25da22dfd99bf874e59d74c304a1d28e921310327c3e4d6960123f2e\"]))),
UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (UtxosFailure (CollectErrors [NoWitness (ScriptHash \"25da22dfd99bf874e59d74c304a1d28e921310327c3e4d6960123f2e\")]))))])""

See on Github

3
  • 2
    Did you find a solution to this? I have the exact same issue Dec 4, 2021 at 10:05
  • I'm experiencing the same problem.
    – Displee
    Dec 18, 2021 at 11:28
  • Trying removing the first 6 bytes from your plutus hex :) Dec 18, 2021 at 18:48

1 Answer 1

1

how you've been building out your transaction? Have you tried using TransactionBuilder?

It seems like you haven't signed your transaction before you tried to send it to the network.

Here's a link to the cardano-serialization-lib doc where they describe how to build transaction using TransactionBuilder.

Also, you can take a look in the spacebudz repo in the initTx method where the TransactionBuilder is used.

Here's a link to the method 👈🏻

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.