I used the great guidance on https://developers.cardano.org/docs/get-started/running-cardano to step by step sync with the Cardano mainnet.

Everything went fine and i was almost done untill 2 weekish ago when synching slowed down dramatically (practically halted) on Epoch 289.

Any idea what i can do to resume the final epochs to fully sync with the mainnet?


[LAPTOP-0:cardano.node.DnsSubscription:Error:254524] [2021-10-02 21:22:51.50 UTC] Domain: "relays-new.cardano-mainnet.iohk.io" Application Exception: MuxError MuxBearerClosed "<socket: 45> closed when reading data, waiting on next header True" [LAPTOP-0:cardano.node.ErrorPolicy:Warning:108] [2021-10-02 21:22:51.50 UTC] IP ErrorPolicySuspendPeer (Just (ApplicationExceptionTrace (MuxError MuxBearerClosed "<socket: 45> closed when reading data, waiting on next header True"))) 20s 20s [LAPTOP-0:cardano.node.DnsSubscription:Error:254541] [2021-10-02 21:22:51.59 UTC] Domain: "relays-new.cardano-mainnet.iohk.io" Application Exception: MuxError MuxBearerClosed "<socket: 49> closed when reading data, waiting on next header True" [LAPTOP-0:cardano.node.ErrorPolicy:Warning:108] [2021-10-02 21:22:51.59 UTC] IP ErrorPolicySuspendPeer (Just (ApplicationExceptionTrace (MuxError MuxBearerClosed "<socket: 49> closed when reading data, waiting on next header True"))) 20s 20s


3 Answers 3


Hmm have you looked into your firewall settings? Has anything changed on your local machine?

The timing of the issue would tell me it's a version issue but the instructions you followed would suggest otherwise. Run:

cardano-cli --version

Should be atleast 1.29 to proceed. Also check the version of DB sync as protocol has been extended post-Alonzo.


Hi I also had the same issue weeks ago,

it got fixed by following this guide: https://forum.cardano.org/t/solving-the-cardano-node-huge-memory-usage-done/67032

Another thing I also noticed is that it can also be fixed by increasing your swap mem.

However, now I am also having problems with epoch 299 from my db sync.

Upon further inspection it has 570k transactions, which is worse than the epoch you have.

Edit: or it could be your version, since there was the alonzo hardfork as patrick mentioned.


Sometimes errors like this can occur when you put the computer to sleep while the node is syncing, if you have a laptop this can occur more frequently due to different methods between deep sleep & light sleep. Laptops are designed to be super power efficient some even turn off the network card depending on which OS & which sleep mode you have enabled. That could very easily cause this sync hang.

Also I see you have followed the Cardano developer docs which take you through the process of running a node as a executable on your machine; I'd recommend running a Docker container since it's easier to use if you get configuration messed up.

Here are some steps I'd take to remedy this since I've seen some Odd things when the following occurs while a Node is running.

  1. Check if the Partition (could be your main drive on your laptop) you are installing this on has enough space to keep syncing the mainnet, mainnet's can be rather large in size so make sure you have enough space.
  2. Make sure the syncing process isn't exceeding the memory limit you have. When I was deploying a node on a low tier server a while back save money I had your issue simply because I didn't have enough memory & the machine was killing background resources until it crash.
  3. Wi-Fi can be spotty so try a hardwired connection.

Other than the following, I don't know what else to tell you, you could always try Docker & see your result their.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.