I have an intentionally small /home partition and a large data partition on Linux. When can I move move Daedalus' data files to my data partition.

I ran out of room on /home and had to move a bunch of stuff elsewhere that I did not want to move.

A long time ago, I tried doing it with symlinks, but that does not work.

I think CH mentioned wanting to add this in one of his AMAs.

  • 2
    Link works. I had shared the immutable folder among three PCs.
    – raghu
    Sep 21, 2021 at 19:27

2 Answers 2


2022 Daedalus 5.1.0

Yes this was a big problem. Daedalus just ate up my SSD while I have a mostly free 2TB HDD sitting doing nothing.

It turned out to be very simple though. Here are the steps for Ubuntu based systems;

  1. Make sure that Daedalus is not running.

  2. Copy the ~/.local/share/Daedalus directory somewhere in your harddisk. In my case I copied it to /mnt/P300/Daedalus.

  3. To back up, I renamed the original like ~/.local/share/Daedalus_

  4. Create a symlink in ~/.local/share to point to /mnt/P300/Daedalus like

    ln -s /mnt/P300/Daedalus ~/.local/share/Daedalus

  5. We are almost finished. Open ~/.local/bin/daedalus-mainnet with an editor. There are two lines starting with exec. In both of them add -m /mnt:/mnt before -m /home:/home. In my case /mnt is where my HDD is mounted. You should first check the mountpoint of your HDD. Perhaps you need to add -m /media:/media or whatever your mountpoint is.

  6. Finally open ~/.local/share/Daedalus/mainnet/namespaceHelper. (now this file is in fact in the HDD since you have already linked at step 4) with an editor and repeat exactly what we did in step 5.

  7. Say some prayers.

Now you are probably OK and when run, Daedalus should start working on the HDD copy.

  • Make sure it finalizes replaying the ledger and synching the blockchain.
  • Make sure everything works just fine.

You may now delete the backup ~/.local/share/Daedalus_ from your SSD.

  • 1
    I still can't try this until I get a new more powerful notebook, but it looks like it will work. Thanks for all the details. I will probably need this in the future.
    – Joe
    Oct 30, 2022 at 21:15

I use symlinks with Daeadalus all the time. I typically don't symlink the entire Daedalus directory. In my case, state-cardano is a separate zfs volume on my system:

ls -hal ~/.local/share/Daedalus/        
total 7.5K
drwxr-xr-x  3 sam users  7 Aug  6 15:25 .
drwxr-xr-x 36 sam users 37 Oct  1 21:23 ..
lrwxrwxrwx  1 sam users 39 Apr 13  2018 devnet -> /home/sam/state-cardano/daedalus-devnet
lrwxrwxrwx  1 sam users 40 Mar 30  2018 mainnet -> /home/sam/state-cardano/daedalus-mainnet
lrwxrwxrwx  1 sam users 40 Feb 17  2021 mainnet_flight -> /home/sam/state-cardano/daedalus-mainnet
drwxr-xr-x  7 sam users  9 Aug  6 15:29 shelley_qa
lrwxrwxrwx  1 sam users 40 Mar 22  2019 testnet -> /home/sam/state-cardano/daedalus-testnet
  • Finally got around to trying this, but I'm missing something. I created /media/dataspace/data/Cardano and moved (using cp -a) /home/bigbird/.local/share/Daedalus/mainnet/ there and replaced the original with a symlink. When I start Daedalus, I get mkdir: cannot create directory '/home/bigbird/.local/share/Daedalus/mainnet': File exists
    – Joe
    Feb 27, 2022 at 5:01
  • I gave up on Daedalus until I get a new notebook. It won't run on mine any more.
    – Joe
    Apr 16, 2022 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.