3

So, the context is I have cardano-wallet and node deployed via docker-compose. I do have mnemonic codes, wallet passphrase, id/label, everything. For alonzo hardfork, I had to upgrade my node which I did. Firstly, since its docker-compose I had to change versions, removed current running containers and build new ones. I did, but node never started, kept restarting, upon investigation logs it was some linux user/permission issue. It made sense that it wasn't going to just work with previous volumes. I went ahead and purged volumes, tried again and good that this time it worked and started syncing.

Using RPC API I restored my wallets, there are about 65k addresses in 1 wallet and 4-5 thousand addresses in other 2 wallets. After restoring, I matched addresses and all of them are a 100% match which validates that private key has been restored correctly but even after complete sync all addresses are marked as "unused" and wallet has "0" balance. :((((

Any help will be appreciated, I have a lot of money in ADA and assets on the line here.

1
  • Hey @FieldMarshal, let us know what you figured out (as it's been 21 days). It will help others in the future who may have similar problems. Oct 4 at 23:12
0

Check your node sync status with cardano-cli query tip. Likely your wallet is synced, but your node is not caught up yet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.