0

Hi I was just following lecture 1 when trying to build the Auction contract.

Plutus commit: ea0ca4e9f9821a9dbfc5255fa0f42b6f2b3887c4

I ran Cabal clean, Cabal update, then added brew install libsodium-dev.

The Cabal build returned this error code:

Referenced from: /Users/kalebamarante/.cabal/store/ghc-8.10.6/lib/libHScrdn-crypt-clss-2.0.0-c5451e6b-ghc8.10.6.dylib
  Expected in: flat namespace
 in /Users/kalebamarante/.cabal/store/ghc-8.10.6/lib/libHScrdn-crypt-clss-2.0.0-c5451e6b-ghc8.10.6.dylib
cabal: Failed to build cardano-api-1.27.0 (which is required by
plutus-pioneer-program-week01-0.1.0.0). See the build log above for details.

How do i fix it?

In case you're wondering, I am running a nix shell in the background.

3
  • Please include OS ver and few commands you ran before this.
    – raghu
    Sep 9, 2021 at 18:54
  • I assume you are referring to Plutus Pioneers Program Iteration 2 - Lecture 1: youtube.com/watch?v=_zr3W8cgzIQ It seems you are using GHC version 8.10.6, but I think the Plutus code only works with GHC version 8.10.4 Here is some documentation on how to setup your environment github.com/nstankov-bg/docs.plutus-community.com/tree/main/book/… Hope you can find something there.
    – j.karlsson
    Sep 11, 2021 at 20:49
  • Hey I made progress getting all the dependencies I needed from the nix virtual environment, I just need to build the code from week01 using cabal and compile it. Sep 22, 2021 at 14:48

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.