3

My cardano node was running normal and all of sudden I get this error, ErrorPolicySuspendPeer (Just (ApplicationExceptionTrace (MuxError (MuxIOException Network.Socket.recvBuf: resource vanished (Connection reset by peer)) "(recv errored)"))) 20s 20s

I have tried restarting the node, but the error is same. Note: I am using testnet. Updated Status: enter image description here

2

Can you provide us with your node version : cardano-node --version And the slot and epoch number at which your node stopped syncing. Thanks

The testnet recently hard-forked into Alonzo era and if your node isn't at version 1.29.0 then you'll have issues syncing past the hardfork. If indeed your node is outdated, download the latest binaries here : Binaries 1.29.0

Also make sure to get the latest configuration files at : Config files

A common fix is also to delete the database folder containing immutable, ledger, ... So try this if the above doesn't apply or solve your issue (this will re-sync your node from epoch 1).

3
  • 1
    This was helpful to some extent. I updated to 1.29. My node is fully synced, but when i run cardano-wallet serve. I get this error cardano-wallet: ExceptionInLinkedThread (ThreadId 15) DecoderFailure Sep 4 at 14:17
  • Unfortunately I'm not that familiar with cardano-wallet, though I would also suggest checking that it is up to date. Good luck Sep 5 at 10:30
  • removing the db folders immutable and ledger was enough for me, although I'm at version 1.27. After deleting them I re-ran cardano-node run ... Glad I didn't need to reinstall all of that lol, took me quite some time just yesterday
    – G-Unit
    Sep 16 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.