5

I tried to compile the cardano-node 1.27.0 for Raspberry PI4 following the instructions and everything gets well until I do the:

cabal build all

Then all compiles until I get this error:

   src/Testnet/Byron.hs:71:20: error: [-Woverflowed-literals, -Werror=overflowed-literals]
    Literal 8000000000000000 is out of the Int range -2147483648..2147483647
   |
71 |   , totalBalance = 8000000000000000
   |                    ^^^^^^^^^^^^^^^^

<no location info>: error: [-Wunused-packages, -Werror=unused-packages]
    The following packages were specified via -package or -package-id flags,
    but were not needed for compilation:
      - ansi-terminal-0.11

Can someone tell me why is this? Thanks

3
  • Hi and welcome to the Cardano stack exchange! Can you please provide a bit more information? What instructions did you follow (link)? And how did you make sure you use the the correct version of the source code?
    – eddex
    Jul 19 at 12:18
  • 2
    Is your Pi possibly running a 32 bit OS?
    – sorki
    Jul 19 at 12:44
  • Oh, thanks! I looked with uname -m and it says armv7l su 32bits. I will download a 64bits os image and try again and update the question.
    – satchcoder
    Jul 20 at 7:50
2

You could have a look at this. It shows how to setup the Pi4 to build cardano-node, but you could also simply run the cardano-node in docker.

1
  • 1
    Welcome to our community! Unfortunately this is a link only answer unless you summarize what that link tells us in terms of showing how to setup the Pi4. This type of answer is best left as a comment, which unfortunately you won't be able to do without earning a bit of reputation by writing high-quality (much longer) answers. Jul 20 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.