I am unable to connect to the Daedalus mainnet for over four days now. The time sync is correct, so that is not the issue. Running Ubuntu 20.04, and have not had this problem for a very long time. I have tried countless times.

  • 2
    What have you done so far to try and work out the issue? Do you have any errors or warnings in the logs?
    – gRebel
    Jun 21, 2021 at 23:06
  • No, but see my comment below. I solved it, but not sure what actually solved it! Thanks
    – Andrew
    Jun 22, 2021 at 13:43

3 Answers 3


Try reinstalling Ubuntu or Linux Mint then install again. It could be multiple things going on so reinstalling the OS for weird stuff can work. I use Linux mint without issues.

  • Hi, I rebooted my modem, rebooted my machine and it finally worked, but it took a long time to connect to the network. So really I have no idea what it was, but it is working now. cheers and thanks
    – Andrew
    Jun 22, 2021 at 13:42

I'm sure there are many reasons why this might happen, but my last experience of this on Ubuntu (Pop OS) was when I was connected to a VPN. Disconnecting immediately solved the problem, so it's possible if you use a company VPN that the network traffic is being blocked for the wallet.

  • Thanks, I don't use a VPN, other than in browser. I don't think I am going toknow what it was, but IOHK checked my logs and said there was an issue, I think maybe at their end, but seems ot be solved now. cheers
    – Andrew
    Jun 25, 2021 at 17:07

Have you tied restarting the Cardano node within Daedalus? I have have flight running on Ubuntu with no issues. Once you reset the node walk away for a bit and come back and see if you've connected.

  • 1
    I think I did something like that. Whatever I did it worked, and there was an issue, which the logs showed, but I am not sure what it was. Works now though. cheers
    – Andrew
    Jun 27, 2021 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.