9

I just updated the daedalus wallets to the 4.1.0 version. When I launch it, it says Verifying the blockchain (50%), once it completes it resets and starts from 0% again. Also, it says: Cardano is not responding and Cardano node is not syncing. I attached a screenshot. Daedalus

I already tried restarting my computer. Does anyone know another solution? Do I have to uninstall and download again?

I've been using daedalus wallet for a while, and this is the first time I have an issue.

1
  • i have the same problem. Did u solve it? U write u letting it run, for how long? Thank you very much! Jul 1 at 17:34
8

This kind of problem seems to be popping up sporadically and without apparent reason. Usually it fixes itself – just keep the node running for several hours. Also restarting the router sometimes helps.

Check here for reference: https://iohk.zendesk.com/hc/en-us/articles/360010522913--Connecting-to-Network-message

3

There was an issue in cardano-node 1.26.1 at least that caused an issue in startup time if the last shutdown did not complete correctly:

https://github.com/input-output-hk/cardano-node/issues/2564

I have generally found leaving the cardano-node alone to do its thing, resolves most startup issues.

1
  • 2
    Yes, I ended up letting it run for a long time, and that solved the issue.
    – Schach21
    Jun 10 at 20:58
2

I had the same issue once where it was stuck on 99.9% for hours on end. I would first suggest simply restarting the Daedalus node to see if it solves it. In my case, that did not work and it got stuck at the same point every time.

What did help was nuking the local chain database, thereby triggering a full re-sync (will take a couple of hours):

  1. Turn Daedalus on
  2. Go to Help -> Daedalus Diagnostics
  3. Find the Daedalus State Directory under Core Info -> open that path
  4. Shut down Daedalus
  5. Inside the directory, you should see a chain subdirectory, enter it
  6. Inside the chain directory, you should see a directory named immutable
  7. Delete everything inside the immutable directory (around 10GB at the moment)
  8. Re-launch Daedalus and wait for the full re-sync

EDIT: This approach will not necessarily work for you - check the comment below for more options.

This worked for me.

2
  • This answer didn't fix my problem, but it got me on the right track. Here's what I did: instead of deleting everything inside immutable, I deleted just the latest 2 months of files. In addition, I had to delete everything inside the volatile and ledger folders. Once I did that, my daedalus client finally got unstuck.
    – crypdick
    Aug 15 at 13:49
  • @crypdick cool, I'll update the answer for folks to check out your comment as well if they run into the same issue! Thanks for the update. Aug 16 at 6:39
1

Try restarting the node from the wallet Help -> Daedalus Diagnostics -> Restart Cardano Node. Then leave it there for awhile and check on it again in a few hours. The connections are still centralized and you could just have to wait in line essentially for a bit.

As a side note this should be much better in the future with the decentralized P2P that will be in test net soon.

Not the answer you're looking for? Browse other questions tagged or ask your own question.