I am trying to follow the project based learning program but get stucked here: https://plutuspbl.io/modules/102/1023

I started the docker container for cardano-node (https://hub.docker.com/r/inputoutput/cardano-node) like this:

docker pull inputoutput/cardano-node:1.35.3-configs
docker run -e NETWORK=preprod inputoutput/cardano-node:1.35.3-configs
export CARDANO_NODE_SOCKET_PATH=/ipc/node.socket

Updated according to previous answer but still not working:

docker pull inputoutput/cardano-node:8.1.2
docker run -e NETWORK=preprod inputoutput/cardano-node:8.1.2

I created my address as described (https://plutuspbl.io/modules/102/1022):

cardano-cli transaction build \
--babbage-era \
--testnet-magic 1 \
--tx-in $UTXO_IN \
--change-address $SENDERADDRESS \
--out-file simple-tx.raw

cardano-cli transaction sign \
--signing-key-file $SENDERKEY \
--testnet-magic 1 \
--tx-body-file simple-tx.raw \
--out-file simple-tx.signed

cardano-cli transaction submit \
--tx-file simple-tx.signed \
--testnet-magic 1

Sending ADA using Lace in Preprod works. I can see the transaction here: https://preprod.cardanoscan.io/address/00afb85707bc11b8a018610da4b79f73d2c3553dedce2a8a414bd2eb974326c013bb1e3aae31194b06e23222a9e47e481db054447fcfae217f

But I cannot find the utxo using

cardano-cli query utxo --testnet-magic 1 --address $SENDERADDRESS

As SENDERADDRESS I tried the generated wallet address (as shown in the lecture) and also my lace address but both are just showing empty results (line of dashes).

If I was using the wrong network not even sending the ADA from Lace should have worked right? Any suggestions what might be wrong?

Update: Turned out I just did not wait long enough. The block of the container tip must of course be greater than the block containing the transaction:

cardano-cli query tip --testnet-magic 1

1 Answer 1


That's an old node version that can't cross the Babbage hard fork. Please update to 8.1.2.

  • Thanks for your answer. I tested again using <pre><code> docker pull inputoutput/cardano-node:8.1.2 docker run -e NETWORK=preprod inputoutput/cardano-node:8.1.2 </code></pre> Again no result using the cli but I can find it here: preprod.cardanoscan.io/address/… Any suggestions? Also from the documentation I expected a version like 8.1.2-configs but it seems 1.35.3-configs was the only tag with a -configs postfix. Are the configs now included in every release?
    – Lars
    Oct 23, 2023 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.