1

I am new to plutus. I am trying to learn plutus for which I am using "plutus-starter" code to begin. while using "cabal build" i am getting following error:

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: Win32-network-0.1.0.0 (user goal)
[__1] trying: base-4.16.4.0/installed-4.16.4.0 (dependency of Win32-network)
[__2] next goal: byron-spec-chain (user goal)
[__2] rejecting: byron-spec-chain-0.1.0.0 (conflict:
base==4.16.4.0/installed-4.16.4.0, byron-spec-chain => base>=4.12 && <4.15)
[__2] fail (backjumping, conflict set: base, byron-spec-chain)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: base, byron-spec-chain, Win32-network

How can I solve this.

1 Answer 1

0

You are using the wrong version of GHC which supplies the base library.

According to https://www.snoyman.com/base/ base version 4.16.* is supplied by ghc-9.2.* .

From the bounds required on base (base>=4.12 && <4.15) I would suspect you should be using ghc-8.10.7.

1
  • I think it solved my problem. Thank you very much. Commented Aug 7, 2023 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.